kingstock
您当前位置:点股成金 >> 公式下载 >> 大智慧L2 >> 浏览软件
大智慧短期大底主图指标公式 k1.0
大智慧短期大底主图指标公式
  • 软件作者: 未知
  • 软件大小: 0KB
  • 软件类别: 国产软件
  • 软件语言: 简体中文
  • 软件评级:
  • 运行环境: WIN9x/Me/NT/2000/XP
  • 更新时间: 2012年03月02日
  • 软件授权: 免费版
  • 所需点数: 0
  • 插件情况:
  • 相关链接:
  • 演示地址:
软件下载
下载地址1
软件简介

大智慧短期大底主图指标公式股票软件源码如下:

input:N(20,1,500,1),P(12,1,30,1);
DRAWGBK(C,STRIP(RGB(10,160,0),RGB(25,15,0),1));
阻挡线:SMA(HIGH,21,2)*1.035,POINTDOT,colorFFFFFF,PRECIS2;
下档线:SMA(LOW,21,2)*0.96,POINTDOT,PRECIS2;
上:=ema(MA(HIGH,3)*1.05,30);
趋势:=ema(MA(LOW,3)*0.96,30);
短期支撑:LLV(CLOSE,N),PRECIS2,color6803C7;
中:=ema(MA(OPEN,3)*0.99,30);
趋势线:=SMA(LOW,8,1);
VAR1:=(OPEN+LOW+HIGH+CLOSE)/4;
VAR2:=((CLOSE-REF(CLOSE,1))/REF(CLOSE,1))*100;
VAR3:=((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18)))*100;
VAR4:=SMA(VAR3,9,1);
VAR5:=SMA(VAR4,3,1);
J:=3*VAR4-2*VAR5;
A2:=EMA(VAR4,3);
A3:=EMA(A2,3);
A4:=EMA(A3,3);
A5:=EMA(A4,3);
AA:=EMA(A5,6);
中期大底:LLV(LOW,30),colorCDFFBB,PRECIS2;
VAR9:=HHVBARS(HIGH,50);
VAR11:=((CLOSE-REF(OPEN,VAR9))/REF(OPEN,VAR9))*100;
DRAWTEXT((CROSS(A4,AA) AND (VAR11<(0- 23))),(LOW-0.3),''),colorFF0000;
STICKLINE((CROSS(A4,AA) AND (VAR11<(0-23))),中期大底,(中期大底-0.27),4,0),colorFFFFFF;
CG:=MA(CLOSE,19);
CD:=MA(CLOSE,2);
MA20:=MA(CLOSE,20);
MA120:=MA(CLOSE,120);
支撑:=EMA(VAR1,5);
压力一:HHV(LOW,20),PRECIS2,Color00FFFF;
压力:HHV(支撑,60),colorD8CFBB,PRECIS2;
短期底部:LLV(HIGH,30),PRECIS2,Color00FF00;
DRAWTEXT(FILTER(((((((CLOSE>CG) AND (HIGH<上)) AND (CLOSE <上)) AND ((趋势线-REF(趋势线,3))>0)) AND ((趋势-REF(趋势,1))>=0)) AND CROSS(CD,CG)),5),(LOW-0.02),'★大底成'),color4D84FF;
DRAWTEXT(FILTER(((CROSS(趋势,中期大底) AND (LOW<=中)) AND ((趋势-REF(趋势,1))>0)),3),(中期大底-0.08),'←分时拉升'),colorFF00FF;
DRAWTEXT(FILTER((CROSS(中,短期底部) AND ((趋势-REF(趋势,1))>0)),4),(中期大底-0.16),'←分时狂牛'),color430CC0;
aaa1:=ema(c,2);
bba1:=ema(aaa1,2);
aa:=ma(bba1,3);
aaa2:=ema((h+c+o)/3,18);
dd3:=aa>=aaa2 and c>aaa2;
dd4:=aa<aaa2 ;
dd5:=aa>aaa2 ;
STICKLINE((dd4 or dd5) and o<=c ,h,l,0.5,0),Color00cc99;
STICKLINE((dd4 or dd5) and o<=c ,c,o,7,0),Color00cc99;
STICKLINE((dd4 or dd5) and o>=c ,h,l,0.5,0),Color3F8C3A;
STICKLINE((dd4 or dd5) and o>=c ,c,o,7,0),Color3F8C3A;
STICKLINE((dd3 or c>aaa2) and o<=c,c,o,7,0),Colorred;
STICKLINE((dd3 or c>aaa2) and o<=c,h,l,0.5,0),Colorred;
STICKLINE((dd3 or c>aaa2) and o>=c,c,o,7,0),Colorff33ff;
STICKLINE((dd3 or c>aaa2) and o>=c,h,l,0.5,0),Colorff33ff;
STICKLINE(MA(C,13)>O and C>MA(C,13) and O<c,O,C,8,0),coloryellow;
STICKLINE(MA(C,13)>O and C>MA(C,13),H,L,0.8,1),coloryellow;
上一:=(SMA(HIGH,21,2)*1.05);
DRAWTEXT((((((CLOSE<REF(CLOSE,1)) AND ((上-REF(上,1))<0)) AND (CLOSE<REF(CLOSE,1))) AND (HIGH>上一)) AND (CLOSE<上一)),(HIGH+0.13),'←分时短线'),colorFFFFFF;
VARQ:=MA(CLOSE,152);
VARW:=MA(CLOSE,194.16);
VARE:=(VARW+(2*STD(CLOSE,170)));
VARR:=(VARQ+(2*STD(CLOSE,170)));
VART:=IF((DATE>1080822),0,1);
VAR61:=EMA(HHV(HIGH,500),21);
VAR71:=EMA(HHV(HIGH,250),21);
VAR81:=EMA(HHV(HIGH,90),21);
VAR91:=EMA(LLV(LOW,500),21);
VARA1:=EMA(LLV(LOW,250),21);
VARB1:=EMA(LLV(LOW,90),21);
VARC1:=EMA(((VAR91*0.96+VARA1*0.96+VARB1*0.96+VAR61*0.558+VAR71*0.558+VAR81*0.558)/6),21);
VARD1:=EMA(((VAR91*1.25+VARA1*1.23+VARB1*1.20+VAR61*0.550+VAR71*0.550+VAR81*0.650)/6),21);
VARE1:=EMA(((VAR91*1.30+VARA1*1.30+VARB1*1.30+VAR61*0.680+VAR71*0.680+VAR81*0.680)/6),21);
VARF1:=EMA((((VARC1*3+VARD1*2+VARE1)/6)* 1.738),21);
VAR101:=REF(LOW,1);
VAR111:=((SMA(ABS((LOW-VAR101)),3,1)/SMA(MAX((LOW-VAR101),0),3,1))*100);
VAR121:=EMA(IF(((CLOSE*1.35)<=VARF1),(VAR111*10),(VAR111/10)),3);
VAR131:=LLV(LOW,30);
VAR141:=HHV(VAR121,30);
VAR151:=IF(MA(CLOSE,58),1,0);
VAR161:=(EMA(IF((LOW<=VAR131),((VAR121+(VAR141*2))/2),0),3)/618)*VAR151;
VAR171:=((IF((VAR161>50),50,VAR161)/20)*15)*VART;
主力吸筹:VAR171>中期大底,colorFF00FF,linethick0;
STICKLINE(VAR171>中期大底,中期大底,(中期大底-0.05),1,0),colorFF00FF;
DRAWTEXT(FILTER((((((LOW<=趋势) AND (CLOSE>趋势)) AND (VAR171>0)) AND ((趋势-REF(趋势,1))>0)) AND (CLOSE>OPEN)),5),(LOW-0.04),'←分时黑马'),color8CF800;
{点股成金-股票公式 www.kingstock.cn}
B1:=(HIGH+LOW+CLOSE)/3;
B6:=HHV(B1,4*15);
B7:=LLV(B1,4*15);
B8:=B6-B7;
飞龙顶底线:=MA(((B1-B7)/B8),2)*80;
DRAWTEXT(FILTER(((((飞龙顶底线<=1) AND (VAR171>0)) AND (LOW<=趋势)) AND (CLOSE>趋势)),3),(LOW-0.04),'←分时短抄'),colorFFFF00;
DRAWTEXT(FILTER((((LOW <= 趋势) AND (CLOSE >= 趋势)) AND ((趋势 - REF(趋势,1))>0)),8),(中期大底 - 0.08),'←分时半仓'),color87D826;
DRAWTEXT((((CROSS(中,短期底部) AND (HIGH<压力一)) AND (HIGH<上)) AND ((趋势-REF(趋势,1))>0)),LOW,'←分时必杀'),colorFFFFFF;
均五:=MA(CLOSE,4);
X7:=EMA(EMA(EMA(HIGH,9),9),9);
海底:=X7*0.92;
海底二:=X7*0.933;
海底三:=X7*0.897;
天际:=X7*1.05;
中线:=SMA(LOW,5,1);
中轨道:=MA(CLOSE,2);
DRAWTEXT(FILTER(((((HIGH>压力) AND (CLOSE<压力)) AND ((趋势-REF(趋势,1))<0)) AND (CLOSE<OPEN)),5),(HIGH+0.12),'●逃'),colorFFFF00;
MA12:=MA(CLOSE,P);
MA42:=MA(CLOSE,42);
DRAWTEXT((((CROSS(中轨道,均五) AND (LOW<=海底)) AND ((均五-REF(均五,1))>0)) AND (CLOSE>=海底二)),LOW,' 底部'),Color00FFFF;
DRAWTEXT(((((CROSS(中轨道,海底) AND VAR171) AND (LOW<=海底)) AND ((MA20-REF(MA20,1))>0)) AND (CLOSE>海底)),(LOW-0.06),'小底不急'),colorBCF0AF;
DRAWTEXT(((((CROSS(中轨道,海底三) AND (CLOSE>OPEN)) AND ((CLOSE-REF(CLOSE,4))>0)) AND (LOW<=海底三)) AND (CLOSE>海底三)),LOW,'底二'),colorFF0000;
MA30:=MA(CLOSE,30);
V1:=HHVBARS(HIGH,100);
V2:=CROSS(MA(CLOSE,10),MA(CLOSE,30));
V3:=(V1>60 AND V2)*100;
DRAWTEXT((((((V3 AND (HIGH<上)) AND (CLOSE<压力)) AND (CLOSE>OPEN)) AND ((上-REF(上,1))>0)) AND ((趋势-REF(趋势,1))>0)),(LOW-0.04),'←量价齐升'),color8B0CFF;
DRAWTEXT(((((V3 AND (HIGH<趋势)) AND (HIGH<天际)) AND ((支撑-REF(支撑,1))>0)) AND ((MA20-REF(MA20,1))>0)),(LOW-0.03),'分时波段介入'),color5BA8FF;
DRAWTEXT(((CROSS(趋势,MA12) AND (CLOSE>OPEN)) AND ((趋势-REF(趋势,1))>0)),LOW,'★分时果断'),colorFF0000;
DRAWTEXT(FILTER(((((((((CROSS(支撑,MA12) AND ((MA12-REF(MA12,1))>0)) AND (HIGH<上)) AND (OPEN<压力一)) AND ((CLOSE-REF(CLOSE,1))>0)) AND ((MA42-REF(MA42,1))>0)) AND (支撑<压力)) AND (支撑>MA12)) AND ((趋势-REF(趋势,1))>0)),6),(LOW-0.02),'←分时回抽'),color4DFFFF;
DRAWTEXT((((LOW<=趋势) AND (CLOSE>=支撑)) AND ((MA120-REF(MA120,1))>0)),(LOW-0.35),'抄底'),colorFF0000;
DRAWTEXT(FILTER(((((((LOW<=短期底部) AND ((上-REF(上,1))>0)) AND ((上-REF(上,1))>0)) AND (CLOSE>OPEN)) AND (趋势线<=短期底部)) AND (CLOSE>=短期底部)),5),(LOW-0.03),'←分时望月'),colorA99FFF;
VAR22:=(CLOSE+HIGH+LOW)/3;
VAR33:=EMA(VAR22,10);
VAR44:=REF(VAR33,1);
FILLRGN(VAR33,VAR44,VAR33 > VAR44),Color0000FF;
FILLRGN(VAR44,VAR33,VAR33 < VAR44),Color00FF00;
DRAWTEXT(FILTER((((LOW<=中期大底) AND ((趋势-REF(趋势,1))>0)) AND VAR171),5),(LOW-0.03),'←●买点出现');
DRAWTEXT(((((LOW<=下档线) AND (LOW<=短期支撑)) AND (短期支撑<=下档线)) AND ((MA20-REF(MA20,1))> 0)),LOW,'←绝佳买点'),colorFF0000;
DRAWTEXT(((((CROSS(VAR33,MA20) AND (LOW<=VAR33)) AND (CLOSE>= VAR33)) AND ((趋势-REF(趋势,2))>0)) AND ((VAR33-REF(VAR33,1))>0)),LOW,'←回头望月'),colorFFF

最新评论

关于我们 | 版权声明 | 诚聘英才 | 联系我们 | 广告服务 | 帮助中心 | 会员登陆 | 友情链接 | 网站地图 | 订阅RSS |